Adobe Reader and Flash Player are part of the Liberty Union Configuration of workstations.  You should not have to install these applications.  Updates to these applications are performed by the District IT Department.  If you should have any issues regarding these applications please submit a ticket.